Digital Item Page Gallery is not loading images

The Digital Item Page Gallery doesn’t display images - see a list blank boxes for each page of the document? Tried using both Google Chrome and Mozilla Firefox browsers (latest version is installed).
Digital Item Page Gallery - Google Chrome

Digital Item Page Gallery - Mozilla Firefox

Hi there
Yes I have been trying to open a document since yesterday. Is there a problem with the site?

Hi, I believe the issue started at least a week ago, as I could not display a number of items last week. Where there was a pdf link (not all digitised items have that option) for a record, I could download that ok and open it in Adobe. The interface to view a digital copy seems to be different as there was a button (bottom right) of the first page displaying to generate a pdf and that appears to have gone away. Now there is this gallery display which isn’t working.

button for Export to PDF:

thank you for your reply
I cannot open or download a document
yesterday I was able to see the first page, then when I started browsing the document the document disappeared and I have the “minute gallery images” that I cannot read.

Thank you for bringing this to our attention. We have been experiencing an intermittent technical problem that prevents access to the digital copies of a small percentage of records.

I have checked the items mentioned in this thread. They all currently appear to display correctly but the PDFs may not be available to download.

If you experience further issues with these or any other items not displaying correctly, please contact us and our Reference staff will be able to assist you.

Yours sincerely,

NAA Reference team

Thanks Jessie, I looked up 20 records and the View Digital copy was displaying the images fine.
For one that I tried the Export to PDF or Print button (where there was not a “PDF (x MB)” button on the record display, and it returned a ‘Server Error’ message. I will create a new post about that.

I’m getting this ‘server error’ message when asking to see the images.
macOS v11.7.10, Safari v16.6.1

I have been trying to save a record as PDF today and cannot see the buttons as in the screenshot posted by another user above? is this a temporary overall problem or an individual record problem.Thanks